A vulnerability in a WordPress plugin has left e-commerce sites vulnerable, according to a report Monday from Defiant, makers of a WordPress firewall plugin.

What caused the vulnerability? The report says hackers are targeting the Abandon Cart Lite for WooCommerce plugin, which is currently installed on more than 20,000 sites. The plugin aims to help sites using WooCommere win back users who abandoned their carts by sending them automated email notifications. The attackers are taking advantage of a stored cross-site scripting (XSS) flaw in the plugin.

How does it work? To infect and take over the sites, hackers added items to a cart, entered fake contact information in the checkout fields and injected malicious JavaScript with a bit.ly link in the “billing last name” field before abandoning the cart. The JavaScript then executes once an administrator logs in to view the list of abandoned carts in their WordPress dashboard.

The code enables two back doors to the site. One lets the hacker create an admin account named “woousers” on the site. The other lists all of the site’s plugins and looks for one that’s been disabled in order to create a backup back door in case the admin deletes the “woouser” account.

What’s being done? The plugin’s maker, Tyche Softwares, learned about the issue from user reports on the WordPress user forum and released a patched version — 5.2.0. If you’re using this plugin, be sure you’ve updated to the current 5.2.0 version and carefully review previous submissions in the database. The latest version also scans for the email address that was registered with the malicious “woouser” account and will delete that user if found.

Unknown vulnerability. “It’s also hard to tell how many successful XSS injections are sitting around waiting for an admin to open that page for the first time,” researcher and report author Mikey Veenstra told ZDNet, which first covered the attack. Veenstra also said that many unwitting sites might have already been attacked but haven’t seen any effects because the exploit hasn’t executed yet.

Why you should care. This is a good reminder that site vulnerabilities can come from many angles. It’s not clear how many sites have been infected or how the hackers were using the exploited sites. The report cautions site owners that the patch does not address the exploit occurring on inactive plugins and also warns that “the nature of the initial XSS payload allows the email address of newly created rogue admins to be changed with very little effort.” In other words, the initial “woouser” name could have be changed to something else and remain undetected.

More about WordPress


LEAVE A REPLY

Please enter your comment!
Please enter your name here